What format does beets expect to see music to be imported


#1

Hi All

so ive been using beets for a while, its a really good program so thanks to the Developers for making it happen!

I have a question, so I have imported a large amount of my music and used a specific format for doing singles (EPs and Vinyl rips) so which is
AlbumType/Album Artist/Year - Album/Track. Title

this gives me a folder of albums, folder of singles automatically.

I then move them from the imported directory into my main organised collection which is done by
Audio/Singles/A/etc etc (I do this bit manually)

I originally scanned these folders but found I had multiple releases of the same single as it was released in the US for example in 1995 but elsewhere in 1996, so to avoid me having to try and go through and remove all the duplicates (library is very large) I decided to rescan the albums but remove the year date from the title, so I have start from new and rescan, however

albums that came up as 99% similarity are now showing as 65-75% although they were previously scanned with Beets so the tags should be right, it only happens on discos releases as I find most of the releases I have are not in musicbrainz

example is below

/downloads/Mandy & Randy Feat. Skedee Wedee/2003 - Jump (Orbit Records) (3 items)
Finding tags for album “Mandy & Randy Feat. Skedee Wedee - Jump”.
Candidates:

  1. Mandy & Randy Feat. Skedee Wedee - Jump (74.5%) (id, source) (Discogs, CD, 2003, Germany, Orbit Records)

so the question is, how should beets be presented with the music to allow me to use the Q option on import as otherwise I have to manually process each one, ive changed the similarity down to 80% but a lot of tracks that are 100% the same as the release beets finds, is less than this figure, ive tried bringing it down to say 60% but then it is incorrectly tagging EPs as the accuracy is lower for a match.

Hope that makes sense and if there is a golden format that beets likes to see

ie. AlbumArtist - Album/Track. Artist - Title then I can bulk rename using tag and rename as a one off

thanks


#2

Unless you’re using the from filename plugin, the beets autotagger is not sensitive to filenames. Int he above example, the bit where it says “(id, source)” is trying to explain why the match is imperfect: there is an ID mismatch, and non-built-in metadata sources are penalized by default. Try taking a look at the ID on the tags to see why the former is the case. For the latter, you can change the source_weight option:


#3

I will check this, however this single was previously scanned and matched with a discogs release and not been touched since *apart from moving it. the tags on the files should in theory should be indentical as its only the file and folder structure I am customising.
im not using the filename plug in and am just going to test by removing the file from the folder structure to see what happens