Importing "better" quality music

I have been using Beets for a while and it is truly an amazing tool. I have it setup perfectly for what I want it to do, primarily have clean tags and file/folder names.

I have just discovered a snag that I cannot get around. I don’t know whether it’s something I am not doing correctly or Beets simply cannot do it.

I am trying to import music from a hard drive (already ran through Beets and properly tagged on another computer) to my main machine. I know it contains some duplicates at a higher bitrate to what I already have. I thought I could just run $ beet imp -A /path/to/folder and that would flag up any duplicates being added. Instead it just populated the album with Tracktitle.1.mp3

I started again and then ran $ beet imp /path/to/folder but that invokes the autotagger, which I don’t need.

Is there anyway to skip the autotagger (from Musicbrainz/Discogs) and jump straight to compare what is already in the database?

I apologies if this has been asked before and will delete if this is a duplicate too.

Indeed; the non-autotagged version does not do duplicate warnings. (It’s meant to be non-interactive.) You can use the duplicates plugin to find them after the fact, though!

Thank you, I thought I was missing something in my config file or a flag in the command. Scared to see what duplicates brings up now!