Having troubles with installation on mac os


#1

Having troubles with installation on mac os… I realize that “Problem to install it on MacOs” is very similar to this thread. I was hoping someone could let me know the folder locations being routed to by the program or whatever might be useful in my success in installing this program. I would love to use it for my music library that I wan’t to be more coherent and accessible. My first problem lies in installing pip.py with python. It can find the files even after some rerouting and shifting stuff around. I also had a problem when trying to skip the pip.py step and just installing beets.io or however it worked. As you can see I a very new to this and any help would be greatly appreciated. Please let me know any crucial info. :slight_smile:


#2

Hi! Can you point to a specific step where you got stuck? What was the error message?


#3

After running Python (latest version) and running the script “python get-pip.py” inside of the Mac OS Terminal. After Python was started I got this error message:

python get-pip.py
File “”, line 1
python get-pip.py
^
SyntaxError: invalid syntax

Hop that made sense haha.
P.S. I tried installing without using pip.py but I get an error message that it cannot find the route directory. Tried creating the proper sting of folders and files but It did not open or run in Python. Thank you for the quick respond also!


#4

Looks like you typed this into the Python interpreter? Instead, just run the command from the shell prompt (what appears when you first open a new terminal window).


#5

When I open the Terminal I a met with this: I am guessing this is called the shell prompt, after running the command I am faced with this issue…

Thanks!


#6

You might want to look at those get-pip instructions again carefully. You need to download a file called get-pip.py and then run it with this command.


#7

I was seemingly able to install pip then I was confronted by this:
Installing pip script to /usr/local/bin
error: /usr/local/bin/pip: No such file or directory
Zols-MacBook-Pro:~ zol$ pip install beets
-bash: pip: command not found
Zols-MacBook-Pro:~ zol$

Assuming installing beets is as easy as “pip install beets”. Then one of my last steps is figuring out this problem of installing the pip profile in the user profiles directory.


#8

Zols-MacBook-Pro:~ zol$ ls ~/Library/Python/2.7/bin
ls: /Users/zol/Library/Python/2.7/bin: No such file or directory
EDIT:


#9

You probably have to run get-pip.py as root. Try running it with sudo like this: sudo python get-pip.py.


#10

I tried running it a few different ways. I think the filename for pip may have changed because there doesn’t seem to be much of a folder for it to search in. On question: Does the command “get-pip.py” need “install” after it and is it searching it’s website or is there a file I need to install?

Zols-MacBook-Pro:~ zol$ sudo python get-pip.py
python: can’t open file ‘get-pip.py’: [Errno 2] No such file or directory
Zols-MacBook-Pro:~ zol$ sudo -s
bash-3.2# sudo python get-pip.py
python: can’t open file ‘get-pip.py’: [Errno 2] No such file or directory
bash-3.2# python
Python 2.7.5 (default, Mar 9 2014, 22:15:05)
[GCC 4.2.1 Compatible Apple LLVM 5.0 (clang-500.0.68)] on darwin
Type “help”, “copyright”, “credits” or “license” for more information.

sudo python get-pip.py
File “”, line 1
sudo python get-pip.py
^
SyntaxError: invalid syntax

Also should I try updating python? python --version


#11

UPDATE: I see the mistakes I made running some pip install commands in Python 3.6 shell right now.


#12

UPDATE: I also tried installing pip through the python shell, terminal, as a root (I’m just trying everything). I took a look back in the output and homebrew wasn’t able to install pip… Is there another alternative… I am not able to locate the pip file and as a result I am not able to activate it. Maybe Im missing something and looking in the wrong place… just let me know :smiley:


#13

You need to run that command in the directory where you downloaded get-pip.py.


#14

I also decided to use the curl command… worked great!
curl https://bootstrap.pypa.io/get-pip.py > get-pip.py

I followed this with the sudo get-pip.py command… it should be downloaded :wink:
Is there a possible way for me to install beets like this using pip? (curl command)
I have tried using easy_install (pip), install and both in the sudo form (sudo -s) but beets is not able to install quite yet. Thank you both for your help :smile:


#15

You’ll just need to find where pip lives, now that it’s installed, and invoke it. You can do that either by giving the full path to the pip program or by adding the directory that contains it to your $PATH, along these lines: http://docs.beets.io/en/v1.4.3/faq.html#say-command-not-found


#16

Thank you for your help. I can’t wait to ise beets!


#17

The issue is that my installer is broken. It is not able to find /usr/bin/local although it exists. Here is the error http://stackoverflow.com/questions/41275541/no-such-file-or-directory-usr-local-bin-pip