Recreate state.pickle file

I’m having an issue, and I don’t know where else to look for help. I had a corrupted state.pickle file that beets was complaining about. (A character that wasn’t allowed in ASCII was the specific complaint.) After trying different things, I finally removed the file, but then beets wouldn’t import anything because it complained of a missing file. Putting in a blank file leads it to complain that it reached the end of the file.

How do I convince beets to recreate a valid pickle file that will allow it to import more, while obviously not having any history of past imports or anything else. I still have my library database in good shape, and it can read it and tell me stats about it.



I’ve been fighting this for hours. Nothing seemed to work - it would always just freeze up, no matter what combination of options I tried. Just now I tried to have it run with -P on the import to not resume any previous imports, and it just worked. I have no idea why it’s different.

So I guess ignore this… I don’t see an option to delete it.

That’s weird; deleting the file should be just fine. Can you include the actual error message you were getting?

I’m sorry, but since it’s now working I can’t. But I did notice later on that my installation had a couple of weird things and some conflicts between Python 2 and 3. I resolved all of that and it’s also speedier now. I think that at least some of my problems were self-inflicted. If it recurs, I’ll see about saving the error messages.

Unless there’s a log file that would persist through reinstalling everything, because in that case if you tell me where to look I’ll see what is still there.


1 Like