Not importing ogg files and unexpected behavior of ignore_video_tracks

Hi all,

Just came across beets and was blown away by the complex flavor and deep red color. Sorry, long day. I meant, the sheer scope and flexibility, and I’m hoping to use this amazing tool on my dog’s dinner of a music library… I’ve noticed some unexpected behavior when testing it out on a minimal set up:

config (v 1.6.0):

directory: /media/foo/music
library: /home/foo/.config/beets/library.db

    move: yes
    copy: no
    write: no
    ignore_video_tracks: no

Beets is refusing to import an album ripped into ogg. -vv and logfile are not really providing any clues as to why. After much faffing around with forum posts, permissions, file naming conventions etc. it occurred to me to look into the ogg container, and sure enough it has a video stream in it (album cover)…

Remove the stream with ffmpeg (demux and pass through vorbis stream only) - now it works.

Reading docs again, there is the ‘ignore_video_tracks’ option, but setting that to ‘no’ still ignores the offending ogg file. What about mkv? If I put both streams, or just the audio stream, into an mkv container both version get ignored.

So I’m a bit confused now. Removing the video stream is not an issue as it’s very fast and and simple, but is the above the expected behavior from beets?

Thanks for clarifying!