Metadata priorities and embedding covers

My music library is pretty cleaned up already - at least on the file level. But when I do an import, beets disagrees on some artist names, track titles and it skips some albums. So I basically end up with a database that isn’t really better at all.

Is there a way beets to just use the metadata from my filenames?

TBH all I want to do is to embed my cover.jpg files into the mp3/m4a/flac files - without moving or renaming the files. Removing genres and other metadata would be nice, too.

Is that possible?

Yo! If you don’t want to move your files, I’d recommend an in-pace, non-autotagged import, as described in the last bullet of the “Configuring” section of the “Getting Started” guide:

And the end of the “Importing Your Library” section:

Namely, disable the importer’s default copying, tag-writing, and auto-tagging behavior.

I’ve already followed that guide and have

  copy: no
  write: no

but it still seems to be skipping albums on import.
IIUC this should not be the case when I use import -A?

Yep, sounds about right. Can you elaborate on what you mean by “skipping albums on import” (perhaps with pasted output) and also include your full config?

I assume it’s because I used import -q. So there also isn’t much output. But then I again I would have thought “skip” in this context means skipping the tagging, not the import.

As for the skipped: After moving, I’ve gone through the library and quite a few albums didn’t have the specified track naming scheme. I didn’t double check but assume those were skipped albums.

I’ll give it a try with import -A

That’s the current config I working with:

directory: path/to/music
library: path/to/library.db
per_disc_numbering: yes
original_date: yes
languages: de en
  color: no

  copy: no
  write: no

sort_album: albumartist+ year+ album+ disc+ track+
sort_item: albumartist+ year+ album+ disc+ track+

plugins: fromfilename discogs inline the edit duplicates missing fetchart #scrub #zero #rewrite

  full: yes

  user_token: <token>

  ifempty: yes
  maxwidth: 1024

keep_fields: title artist album year track images

    '[\\/]': ' '
    '^\.': _
    '[\x00-\x1f]': _
    '[<>:"\?\*\|]': _
    '\.$': _
    '\s+$': ''
    '^\s+': ''
    '^-': _
asciify_paths: yes

  disc_and_track: u'%i-%02i' % (disc, track) if disctotal > 1 else u'%02i' % (track)

format_item: Bands/%the{$albumartist}/$year [$album]/$disc_and_track $title
format_album: Bands/%the{$albumartist}/$year [$album]/$disc_and_track $title

  default: Bands/%the{$albumartist}/$year [$album]/$disc_and_track $title
  singleton: Singles/[$artist] $title
  comp: Compilations/$album/$disc_and_track [$artist] $title
  albumtype:soundtrack: Soundtracks/OST $album/$disc_and_track [$artist] $title

I now did an import -A but how can I see what metadata beets has on my files?
list just shows the path, fields just the fields. Isn’t there a way to see the populated fields for the various tracks and albums?

Aha, yes, it does mean “skip the import.” To change that, use the quiet_fallback config option:

See the -f flag to the list command or the info plugin (in library mode).

So I guess quiet_fallback: asis should make it work the way I thought it would.

Well, the -f flag needs me to specify a format, but I rather want to see a all fields.
But it looks like info -l is what I am after.

Not sure what “library mode” is though. Searching in the docs did not help either.

Thanks for the help!