Need help with config


#1

So I used to be able to do this no problem, but since I reinstalled I have been having issues. I want my folder to look like:

Music
|- Digable Planets - Blowout Comb
—|- 01 - The May 4th Movement
—|- 02 - Black Ego

I followed the instructions for configuring in the documentation, but have been unable to get this format. When I change format_item and format_album, they are not doing anything. And I have not figured out how to stop it from putting the albums into folders by artist. Could you please tell me what I should have in my config.yaml. This is what it currently looks like:

directory: E:\Music
library: E:.data\Beets\beetsLibrary.db
import:
—move: yes
format_item: $track - $title
format_album: $artist - $ album
sort_item: album+ track+


#2

The configuration section you’re looking for is paths (see the getting started guide for more details). The format_* options are for printing out music in the console.


#3

Thank you, however now I am getting the error "configuration error: paths must be a dict, not unicode"
I have no idea what this means.
my line is:
paths: $albumartist - $album/$track - $title


#4

Please take a look back at the documentation for that option—there’s also an example on the main configuration page in the docs that shows how to use it. In short, you put a series of different templares under paths:, where the “main” one is labeled default:.