Beatport plugin - fetching metadata only on individual tracks in a folder


New to beets.
Before I’m going to spend time on diving in deeper, I skimmed over the documentation, but it’s not clear if I can do the following:

Let’s say, I have tracks downloaded from Beatport in WAV format, therefore not having any metadata.
I stripped them from the id_1234 that’s in the filename and converted them to FLAC with Artist-Title from filename to tags.
This way the input would be Artist + Title tag.

Now I want them to be processed with beets, fetching Beatport metadata/cover art only.

Is this possible?
And if so, how should I approach this?

Mind you, those are not albums, but individual tracks in a folder.

Sure! You’ll want to use the fromfilename plugin to attempt to guess the metadata from the filenames. And you’ll want to use the beatport plugin, of course, to look up data there. Finally, use the -s flag to the beet import command to import single files. Give it a shot and see how it goes!



So here’s what I did:

  1. pip install beets
  2. edited the config.yaml file to set directory and db path
  3. ran beet import -A f:\my-music-folder-to-be-processed
  4. enabled the beatport plugin by adding plugins: beatport in the config.yaml
  5. installed it thru pip install beatport
  6. checked if enabled using beet version, and yep, it shows.
  7. pip install requests requests_oauthlib show it’s already satisfied
  8. ran beet import f:\beets-music -s
  9. go to the url stated to authorize, and login with my beatport account, paste the token string back into beets

Now I’m asked to individually select which candidate the track belongs to?

I don’t want that, I just want it to search for the best candidate itself, like autotagging.
I know how to disable autotagging using -A, but not how to enable the autotagging.
Or is this only possible AFTER i manually select to which candidate the track belongs?


I managed to fix the unsupported Colorama, by using ConEmu instead of cmd.

I also found the undocumented distance_weight parameters.
So I set everything to 0.0, except (track)Artist + trackTitle.

The distance_weight source i kept at 2.0 - what does this do?
I want to be the source Beatport only, so maybe it will help if you can clarify this parameter.

I notice the treshold is around 95% match and higher, will tag automatically.
Can I bump this % up, so it will match on for example, 70% and higher?

You’ll want to turn the weight down to zero to avoid penalizing matches based on source altogether.