How to override one artist name

I have a CD by Ofra Haza - this is the CD in case that’s relevant: https://musicbrainz.org/release/041fd465-7b74-4c0c-b326-bfb348adb3d1

The meta tags for her name look like:
comment[3]: ALBUM ARTIST=עפרה חזה
comment[4]: ALBUMARTIST=עפרה חזה
comment[5]: ALBUMARTIST_CREDIT=Ofra Haza
comment[6]: ALBUMARTISTSORT=Haza, Ofra

I want the directory filename to be ‘O/Ofra Haza/’
but it was creating ‘_/עפרה חזה/’
I then added ‘asciify_paths: yes’ to my config file
and now it creates _/`prh\ KHzh/

I understand why it’s doing this, and no disrespect to the culture, but how can I get this to show up as ‘O/Ofra Haza/’? Can I do something in my config file for this one artist, even if that is a hack?

FYI, I tried adding “language: en” to my config file and re-importing this one, but it made no difference.

asciify-paths: yes

https://beets.readthedocs.io/en/stable/reference/config.html#asciify-paths

After adding “asciify_paths: yes” to my config file, it changed the path from
/עפרה חזה/"
to
"
/`prh KHzh/”

But I want it to be “O/Ofra Haza/”

The option is called languages, not language, FYI:
https://beets.readthedocs.io/en/stable/reference/config.html#languages

But of course, that only works if MusicBrainz has the appropriate alias information. You may consider just doing beet modify -a 'עפרה חזה' albumartist='Ofra Haza' to make the change yourself.

Thanks, adrian.
I tried “languages: en” and it made no difference.

I used your suggestion of modifying albumartist, and that did accomplish what I wanted, but this could get un-done if I ever do a full refresh (reimport) of my database, right? I guess that’s something I’ll just have to keep in mind.

1 Like

in your config.yaml file, you can always add this in the replace section

replace:
    'עפרה חזה': 'Ofra Haza'

This will replace every use of ‘עפרה חזה’ with ‘Ofra Haza’

This will not get over ridden on a re-import

I like the ‘replace’ solution better - thanks!

If you set a primary EN alias on musicbrainz and sync with musicbrainz (mbsync?) you should be able to have it match correctly. I do this to allow my changes to be used by everyone.

This artist, Ofra Haza, already has a primary EN alias, but I don’t see how that helps my local file naming?