Force discogs default search?


#1

Beets is fantastic and I have only begun to test it on my collection. I think I have read nearly all the documentation but cannot see if there is a way in the config file to tell it to search discogs before musicbrainz, or to only search discogs.

My preference for discogs is because I have contributed a lot of information to the database and know all the data for my CD rips to be accurate on there. I have also found adding the discogs ID for releases not found immediately has been the best way to get the job done.

Thanks for Beets.


#2

We don’t currently have a way to disable MusicBrainz, but here’s the relevant bug: https://github.com/beetbox/beets/issues/400

One thing you can do, though, is disable the default (small) match penalty the discogs plugin applies to itself. Here’s the config stanza to do that:

discogs:
    source_weight: 0.0

#3

Thanks.

Do you think I could use some of the musicbrainz settings to trick it into almost never matching? For example by using the country or another setting? What could you recommend?

I see that is an old feature request, is it something that might get implemented?


#4

Hmm; I suppose you could try setting the MusicBrainz host to 127.0.0.1! You’d probably get a bunch of ugly errors about the server not being reachable, but it would certainly stop the system from getting any MB hits.

We have quite a few old feature requests. :smiley: In general, all such requests are candidates to be added, as soon as someone finds the time and energy to tackle it. I can’t promise anything personally, but options always include putting something together yourself or bribing another developer. :sparkles:


#5

Thanks, I tried changing the host to localhost and it broke it. Gave me the following error and then seemed to ignore Discogs. Then when I removed the host from config the error continued until a computer restart.

Error: MusicBrainz not reachable in release search with query {‘release’: u’the man’, ‘tracks’: u’3’, ‘artist’: u’anthrax’}


#6

Ah yes, I suppose that would cause a fail-stop error. Sorry that wacky workaround idea didn’t work!