Beets does not accept MusicBrainz ID for group releases


#1

I am new to beets and trying out import.

First problem I encountered has to do with a large classical music collection, 111 Years of Deutsche Grammophone. On the first (out of 56) CD, beets stop and ask for help. I tried pasting the MusicBrainz release ID, but i only get a

No matching release found for 26 tracks.

even though the CD’s ID is exactly what I have in the library.
Any suggestion on how I can solve the issue?


#2

Adrian can correct me if I’m wrong, but I believe beets is going to want to match against all 56 CDs at once. It’s failing to match against CD1 because as far as beets is concerned, you’re missing 55 CDs worth of songs.

This will also have consequences for the path names once you do import all 56 CDs. I’d recommend at least enabling multidisc numbering. You could also arrange your paths with an if statement to look for a $disctitle with multidisc releases.


#3

Indeed; beets will try to match the entire release at once. It should try doing that, however, and tell you most tracks are missing, rather than just giving you an error—is there anything useful in the verbose log?


#4

adrian http://discourse.beets.io/u/adrian Leader
January 29

Indeed; beets will try to match the entire release at once. It should try
doing that, however, and tell you most tracks are missing, rather than just
giving you an error

Ah, it was not clear from the message that beets was trying to match the
whole 56 CDs.
However, pasting the MBID for the whole set does not seem to work either,
even though the output is different.
Here is what happens:

  1. I get the question about CD 1

  2. I paste the MBID for the whole release

  3. beets thinks about it for a few minutes, then spits the complete list of
    all tracks from the 56 CD release and asks me if Want to accept it

  4. I accept

  5. Surprisingly (because I thought it would have now read the whole 56
    CDs), beets now reads CD 2 and asks me again what I want to do because it
    cannot find a match .

  6. I enter the MBID of the whole release again (with a a growing suspicion
    things will go south again)

  7. beets now complains that the album (CD 2 of 56) is already in the
    library.

  8. I abort

—is there anything useful in the verbose log?

How do I get one of those? The regular log has a simple line for the whole
operation detailed above:

import started Sun Jan 28 19:37:55 2018
duplicate-skip /music/111 Years Of Deutsche Grammophon - The Collector’s
Edition 2 (56 CD)/02 - Abbado - Bizet - Carmen - Part 2

Cheers,

S.


#5

If you’re interested, there’s an FAQ about how to tag multi-disc albums. There’s also an FAQ about reporting bugs that talks about the -v option for verbose output. :slight_smile:


#6

adrian http://discourse.beets.io/u/adrian Leader
January 29

If you’re interested, there’s an FAQ about how to tag multi-disc albums.

I had read the multi-CD FAQ, but I could not follow the advice about
folders’ heuristics, because I cannot touch filenames on the server. My
eyes had glazed over the --flat option, to be frank. Sometimes it is hard
to understand suggestions when you know close to nothing about a program’s
behavior.
Unfortunately, even with the --flat option I get the same behavior as
described above (it just took way longer to process. beet did go through
the 56 CD).
I will put together a bug report tomorrow.

There’s also an FAQ about reporting bugs that talks about the -v option
for verbose output. :slight_smile:

That one I missed…