Beets with Plex?

Ugh

So a while back I was convinced by a friend to install Plex. My experience has been less than the Awesomeness promised by said “friend”. In fact we hit a new low when our last-mile connection was taken down after a storm for repairs, Plex desktop could connect to the cloud to verify the account to connect to the server in the basement…

So as part of the re-think of my house media I am looking to get my music organized and found beets.
Got beets installed, did a basic config file as per the Getting Started Doc and then I ran into:

could not list directory /Media/Music/MeatLoaf-Very Best Of/CD 1/CD 1: Permission denied
and
unreadable file: /Media/Music/Once - Music From The Motion Picture/12 Glen Hansard and Marke?ta Irglova? - Once.mp3

Now I am pretty sure this is from the incredibly crappy permission settings required by Plex, but I’m a bit worried it’s far more sinister in that /Media/Music reside on a different server… My user has full permissions on that share but I’ve run into something like that before.

Please tell me it’s just Plex…

It does indeed look like there is some permissions wonkiness going on. Can you verify that you have the permissions you think you have in these ways?

  • ls -ld '/Media/Music/MeatLoaf-Very Best Of/CD 1/CD 1'
  • ls '/Media/Music/MeatLoaf-Very Best Of/CD 1/CD 1'
  • touch '/Media/Music/MeatLoaf-Very Best Of/CD 1/CD 1/foo.txt'

Then you can delete that foo.txt, if it gets successfully created.

@adrian

here are the results of what you asked for:

ls -ld /Media/Music/MeatLoaf-Very\ Best\ Of/CD\ 1/CD\ 1/
drw-r–r--+ 2 bert www-data 0 Jun 15 2010 /Media/Music/MeatLoaf-Very Best Of/CD 1/CD 1/

ls /Media/Music/MeatLoaf-Very\ Best\ Of/CD\ 1/CD\ 1/
ls: reading directory ‘/Media/Music/MeatLoaf-Very Best Of/CD 1/CD 1/’: Permission denied

touch /Media/Music/MeatLoaf-Very\ Best\ Of/CD\ 1/CD\ 1/foo.txt
touch: cannot touch ‘/Media/Music/MeatLoaf-Very Best Of/CD 1/CD 1/foo.txt’: Permission denied

I’m a bit confused how my user has rw permissions on the directory yet I can’t read or write to it.

My smb.conf file has my user listed as the valid user, and writable is set to ‘yes’.

You will need the “execute” bit enabled to read directories. :slight_smile: Sounds like that smb.conf might need additional fiddling?

@adrian
ah, I missed that, Thanks!
Nope not the smb.conf file but me chmodding the directories so Plex would work. 664 for directories and 755 for files or some such nonsense

Hopefully the other way around (755 for directories and 644 for files)!

The 7 vs 6, 5 vs 4 is the execute permission needed to access files inside the directory.