VA / compilation tracks being duplicated on each import


I need some help finalizing my config. It can be found here -

Problem Overview:
Tracks in VA / comps are being duplicated on each import. It’s also not labeling/naming various artist and comp releases properly + lumping multiple comps together in odd ways.

This has left me with a VA folder full of mislabeled releases with up to 30+ duplicates of each song (1 per import).

All single artist non VA / Comp releases are being categorized and named correctly.

I’m categorizing everything alphabetically, then naming each album by
Artist - Year - album {LABEL - RELEASE Number - release year - Format} [Quality]

i.e. EELS - 1996 - Beautiful Freak {DreamWorks Records - DRD 50012 - 1997 - DE - CD} [FLAC]

There are some other oddities but that’s the big one I need to resolve right now.

Any help would be greatly appreciated, I’m lost at this point.

Add the following lines to your config:

    albumartist:various\ artists: VA/%bucket{%asciify{%left{%the{$album},2}}}/$album - %if{$original_year,$original_year,$year} %if{$u_version,{$u_version$} }[$u_format]/$disc_and_track - $artist - $title 
    albumartist:various: VA/%bucket{%asciify{%left{%the{$album},2}}}/$album - %if{$original_year,$original_year,$year} %if{$u_version,{$u_version$} }[$u_format]/$disc_and_track - $artist - $title

I found not all VA albums are marked as comp

Ok, I’ll add that now. Thank you

Will that also resolve how it’s duplicating tracks every time I run an import? I have it scanning the same folder, it’s only supposed to import stuff that’s not in the database already, but it reimports any va / comp and adds duplicate files naming them as 1,2,3,4 on each pass i.e. track1.flac, track2.flac etc

Also what’s the best way to clean up the VA / comp folder in my existing library to remove all the duplicates and name releases appropriately?

Also, do I add this under Paths: ?

Do you have beets configured to copy music in to the library rather than move?
I believe ‘copy’ is the default action


It’s set to copy. I need to leave the original folders intact.

Add those lines under the paths.

Add the lines to your path config the try

beet move -p

This will tell you if the changes actually brings those albums back together in the VA folder.

I am not sure why it duplicates at each import, I use move as my default.

Does beets ask you to:

[S]kip new, Keep both, Remove old, Merge all?

when it detects a duplicate?

Try the following to see in verbose mode, as well as pretending why it does not detect the file already existing.

beet -vv imp -p <music directory> 

Ok, thanks! I’ll try that this evening.

It doesn’t prompt me at all during imports because I have it set to quiet and fallback asis. i.e.
quiet: yes
quiet_fallback: asis

Could that be why?

It doesn’t duplicate anything except what it puts in the VA folder.

The quiet option should skip the file if it is unknown. In my config I have

    quiet_fallback: skip

I do not have the quiet option set, I use the -q flag if I have a lot of music to import.

Looking at the code in, I think those two options will always import the item.