Unattended import with --search-id

Hi everyone,

I want to be able to run completely unattended import tasks. For that, I have individual tracks and I add the Spotify album ID to pass to the import command with --search-id.

That works really well as it very quickly matches the track I’m importing with the correct Spotify album. The issue is that even though I am 100% sure that the match is good (as I pass the correct album ID), sometimes beets reports a low enough match so that it still asks for confirmation.

I tried to pass -q but then it skips the import.

How can I default to Apply so that I can have a fully automated import?

Thanks in advance!

I overlooked the docs multiple times. There’s a quiet_fallback option that can be added to the configuration with value asis, but then ignores the --search-id and apply as quiet fallback value is not valid. Is there some other way to achieve what I’m trying to achieve?