Please help newbee get started - Bash shell on Windows


#1

I installed beets/Python on Windows. Installation seemed to go fine. Running in a Windows Cmd window displays a lot of garbage characters, so I am trying to run beets now in a Bash shell.
“beet --version” displays:

    beets version 1.4.7
    Python version 3.7.2
   plugins: fetchart 

My config is:

    directory: D:/tmp/MUSIC
    library: D:/tmp/MUSIC/musiclibrary.db
    import:
        copy: no
        log: beetslog.txt
    art_filename: cover
    plugins: fetchart

I put some sample music in D:/tmp/MUSIC
When I run: "beet import “/d/tmp/MUSIC” in the Bash shell, I get a Traceback displayed (see below).
If I run it in a Windows CMD, it appears to start working and correcting tags, but it displays too many garbage characters.

UPDATE: I installed ComEmu and it works now in it’s terminal window. I would still be interested in knowing why it doesn’t work in Bash and what the Traceback below means.

Traceback:
Traceback (most recent call last):
File “C:\Users\johnp\AppData\Local\Programs\Python\Python37-32\Scripts\beet-script.py”, line 11, in
load_entry_point(‘beets==1.4.7’, ‘console_scripts’, ‘beet’)()
File “c:\users\johnp\appdata\local\programs\python\python37-32\lib\site-packages\beets\ui_init_.py”, line 1256, in main
raw_main(args)
File "c:\users\johnp\appdata\local\programs\python\python37-32\lib\site-packages\beets\ui_init
.py", line 1243, in _raw_main
subcommand.func(lib, suboptions, subargs)
File “c:\users\johnp\appdata\local\programs\python\python37-32\lib\site-packages\beets\ui\commands.py”, line 943, in import_func
import_files(lib, paths, query)
File “c:\users\johnp\appdata\local\programs\python\python37-32\lib\site-packages\beets\ui\commands.py”, line 913, in import_files
session.run()
File “c:\users\johnp\appdata\local\programs\python\python37-32\lib\site-packages\beets\importer.py”, line 329, in run
pl.run_parallel(QUEUE_SIZE)
File “c:\users\johnp\appdata\local\programs\python\python37-32\lib\site-packages\beets\util\pipeline.py”, line 445, in run_parallel
six.reraise(exc_info[0], exc_info[1], exc_info[2])
File “c:\users\johnp\appdata\local\programs\python\python37-32\lib\site-packages\six.py”, line 693, in reraise
raise value
File “c:\users\johnp\appdata\local\programs\python\python37-32\lib\site-packages\beets\util\pipeline.py”, line 312, in run
out = self.coro.send(msg)
File “c:\users\johnp\appdata\local\programs\python\python37-32\lib\site-packages\beets\util\pipeline.py”, line 194, in coro
func(*(args + (task,)))
File “c:\users\johnp\appdata\local\programs\python\python37-32\lib\site-packages\beets\importer.py”, line 1351, in lookup_candidates
task.lookup_candidates()
File “c:\users\johnp\appdata\local\programs\python\python37-32\lib\site-packages\beets\importer.py”, line 641, in lookup_candidates
autotag.tag_album(self.items, search_ids=self.search_ids)
File “c:\users\johnp\appdata\local\programs\python\python37-32\lib\site-packages\beets\autotag\match.py”, line 432, in tag_album
_add_candidate(items, candidates, id_info)
File “c:\users\johnp\appdata\local\programs\python\python37-32\lib\site-packages\beets\autotag\match.py”, line 377, in _add_candidate
dist = distance(items, info, mapping)
File “c:\users\johnp\appdata\local\programs\python\python37-32\lib\site-packages\beets\autotag\match.py”, line 246, in distance
album_info.album_id)
File “c:\users\johnp\appdata\local\programs\python\python37-32\lib\site-packages\beets\autotag\hooks.py”, line 461, in add_equality
if self._eq(opt, value):
File “c:\users\johnp\appdata\local\programs\python\python37-32\lib\site-packages\beets\autotag\hooks.py”, line 436, in _eq
if isinstance(value1, re._pattern_type):
AttributeError: module ‘re’ has no attribute ‘_pattern_type’


#2

Hi! We have an unreleased fix for this—if you can, please run from source (there are instructions in the FAQ) until the new version is out (which will, hopefully, be very soon).


#3

Thanks adrian! This appears to be working OK now. Since I’m a newbee, I still need to learn HOW to use beets. But at least it is not giving a Traceback nor displaying garbage characters in Bash.