ImageMagick installed, but not associated with beets

Hi all. I’m pretty much brand spanking new to I’ve known of this program for a while and also tried and failed to use it a few times in the past…but now i’m giving it a good college try to be able to eventually automate the tagging process for myself.

I’m on a windows installation

Currently, I’m struggling a bit on getting the “fetchart” plugin to work properly because it doesn’t know about ImageMagick.
I have installed ImageMagick using the default settings, but when i run an import, i get the feedback
“embedart: ImageMagick 6.8.7 or higher not installed; ‘compare_threshold’ option ignored
Import of the directory:”
And later in the script i get…
“fetchart: Could not get size of image (please see documentation for dependencies). The configuration options minwidth, enforce_ratio and max_filesize may be violated.”

I assume the second feedback is because of the first issue. I have been looking, but i have not found a solid doc on how i can associate the two or where imageMagick needs to be installed…again i just simply accepted the defaults of the installation on imageMagick.

The docs on beets is VERY good btw…probably the best i’ve seen aside from MAME documentation. But still not finding how i was supposed to relate the two programs…my thought is that if the program just existed on the machine, then beets would know about it, but perhaps i need install imageMagick is a specific directory or specify an install path somewhere…I just don’t know where.

Here is my config file…so far

directory: \\souce\test11\
library: C:\Users\downloader\AppData\Roaming\beets\musiclibrary.db

per_disc_numbering: yes

    default: $albumartist/$year - $album %aunique{}/$albumartist - $album ($year) - Disc $disc - Track $track - $title - $format - $bitrate
    singleton: Singletons/$artist - $title
    comp: Various Artist/$year - $album %aunique{}/$albumartist - $album ($year) - Disc $disc - Track $track - $title - $format - $bitrate
    albumtype:soundtrack: Soundtracks/$year - $album %aunique{}/$albumartist - $album ($year) - Disc $disc - Track $track - $title - $format - $bitrate
    keys: albumartist album
    disambiguators: albumtype year label catalognum albumdisambig releasegroupdisambig
    bracket: '[]'
  # write metadata to music files
  write: yes

  # move imported files from source to the music directory
  move: yes
  resume: ask
  log: C:\Users\downloader\Downloads\NZB Downloads\Beetslog\beetslog.log
plugins: [

  auto: yes
  cover_names: cover front art album folder
  minwidth: 500
  enforce_ratio: yes
  sources: coverart albumart lastfm amazon google fanarttv filesystem
  auto: yes
  cover_names: cover front album art
  minwidth: 500
  enforce_ratio: yes
  sources: coverart albumart amazon google fanarttv filesystem
  auto: yes
  compare_threshold: 50
  ifempty: yes

  auto: yes
  format: (feat. {0})

  auto: yes
  count: 1
  force: no
  source: track

um…maybe nevermind. After closing my command prompt and leaving the computer for a while, coming back and trying a new import with a new command prompt I did not get the error messages this time…maybe reopening the command prompt did something…? I really don’t know.

1 Like