Beets-Docker-Synology running with no outputs

Hi there,

I have installed beets on my Synology NAS, trough the standard Docker of DSM 7using this container: Docker Hub

Everything looks fine, but when i run the import command nothing happens. I just see the processor running the import process, but no output in terminal. Checked the logs and there’s nothing in there. Any ideas why i am stuck ?

Adding the config file and other Synology Docker specifics.

plugins: fetchart embedart convert scrub replaygain lastgenre chroma web
directory: /music
library: /config/musiclibrary.blb
art_filename: albumart
threaded: yes
original_date: yes
per_disc_numbering: no
    default: $albumartist/$album%aunique{}/$track - $title
    singleton: Non-Album/$artist - $title
    comp: Compilations/$album%aunique{}/$track - $title
    albumtype_soundtrack: Soundtracks/$album/$track $title 
    write: yes
    copy: no
    move: yes
    resume: ask
    incremental: yes
    quiet_fallback: skip
    timid: no
    log: /config/beet.log

    auto: yes
    source: album

    auto: yes

    auto: yes
    auto: no

    auto: yes

    '^\.': _
    '[\x00-\x1f]': _
    '[<>:"\?\*\|]': _
    '[\xE8-\xEB]': e
    '[\xEC-\xEF]': i
    '[\xE2-\xE6]': a
    '[\xF2-\xF6]': o
    '[\xF8]': o
    '\.$': _
    '\s+$': ''

    port: 8337

Maybe running beets in verbose mode (beet -vv import) would reveal something?

Does it eventually terminate and return to the prompt, still with no output? How long does it take?

Is it possible there is just a lot of stuff in /downloads and it takes a long time for the disk I/O and for beets to sort through it?

I second the suggestion to use beet -vv.

Thanks guys ! It worked in verbose mode. Merry Christmas!

Hi @simistef You say

Any idea why it worked now, but not before?? Verbose mode shouldn’t change what beets is doing…

I guess it’s because beets is running quite slow on my Synology NAS and without seeing any logging I expected that it’s just not working. as mentioned above the process was rising in usage though, but learned later that it’s up and down all the time. So verbose mode now gives me much trust that things are going on, but indeed there should be no difference in execution.