Beet debug mode (-vv) enables Quiet mode


#1

Hi.

I have moved my audio files and my beets db.
I also split my config file as I will have 2 db’s. One for me and one for my wife.

I did all the changes to the config file to show the changes.
A simple ls gave me no results. So I just did a re-import.
beet --config ~/beets/Vissie_beets.yaml import ./Vissie/
That ran for about an hour 1/2. Then stopped. Like hang, no error, no movement, just sat there. I left it fro 24 hours. No movement.
I then re-ran it, saw that it stopped after about a hour and 1/2.
I tried LOTS of things. I deleted my db tried to rebuild it.
Eventually I decided to run the command without the -vv. Bang! It is asking my input again!

So it seems that -vv places beets in a quiet mode. I’m not sure if this is the desired behavior.

Vissie


#2

Strange! There should be no interaction between verbose mode and quiet mode (or disabling prompts). Is there a way to reproduce the problem?


#3

Hi,
I THINK I know what is happening.
As I start my import process, beets shows me a option. Because I have threading, and or the way beets works, it actually continues in the background. But as I have verbose enabled, the options gets taken away by all the other tasks. So what looked like quiet, is just the fact that the questions asked is way back in history. So if you actual leave it for a hour or so, when the updates stop, and you hit enter, you get prompted to supply a valid option, or beets will take whatever is default. The the rest of the process works as expected.

As this is very strange behavior, I turned off verbose and -vv. Now beets stops at the question asked and I can read what to answer and move on.

Vissie


#4

Yep! Verbose mode does print a lot of messages, and that can bury the prompts.