Why can't i modify the albumartists field

I am trying to move all my soundtracks to the same artist container within kodi. From what i have read, it likes the albumartist tag, when i try to set this as “soundtrack” within beats, it runs the command, but the info command doesn’t show anything as changed…why not? Did i not do something correct?

You will need to use the -a flag to the modify command. See also:

i tried that, doesn’t seem to work, it’s still blank before and after…the weird thing is that if i run it again it says there’s no changes to make…yet the field is still showing as blank…just to be sure i popped the cd into music brainz for a sanity check and the albumartists field shows as blank there also

here’s my config, maybe i have something contradicting it

# files/directories matching one of these patterns are ignored during import
ignore: [".*", "*~", "System Volume Information", "lost+found"]
ignore_hidden: yes

# Paths ----------------------------------------------------------------------

# Paths and filenames for music files
# relative to music directory

directory: \\Aries\Multimedia\Music\
library: C:\Users\downloader\AppData\Roaming\beets\musiclibrary.db

per_disc_numbering: yes

    default: Artists/$albumartist/$year - $album %aunique{}/$albumartist - $album ($year) - %if{$multidisc,Disc $disc -}Track $track - $title - $format - $bitrate
    comp: Compilations/$year - $album %aunique{}/$albumartist - $album ($year) - %if{$multidisc,$disc-} Track $track - $title - $format - $bitrate
    albumtype:soundtrack: Soundtracks/$year - $album %aunique{}/$albumartist - $album ($year) - %if{$multidisc,$disc-} Track $track - $title - $format - $bitrate
    singleton: Singletons/$albumartist/$year - $album %aunique{}/$albumartist - $album ($year) - %if{$multidisc,$disc-} Track $track - $title - $format - $bitrate
sort_album: albumartist+ album+
sort_item: artist+ album+ disc+ track+
sort_case_insensitive: no

    keys: albumartist album
    disambiguators: album albumtype year label catalognum albumdisambig releasegroupdisambig
    bracket: '[]'

    multidisc: 1 if disctotal > 1 else 0
  # write metadata to music files
  write: yes

  # move imported files from source to the music directory
  move: yes
  #Singletons/$artistresume: ask
  log: C:\Users\downloader\AppData\Roaming\beets\beetslog.log
  quiet_fallback: skip
  #timid: yes #Asks decision for every album import
# Auto Tagger ----------------------------------------------------------------    
    #ignore_video_tracks: no
    strong_rec_thresh: 0.04
    medium_rec_thresh: 0.25
    rec_gap_thresh: 0.25
       missing_tracks: medium
       unmatched_tracks: medium
    ignored_media: ['Data CD', 'DVD', 'DVD-Video', 'Blu-ray', 'HD-DVD',
                   'VCD', 'SVCD', 'UMD', 'VHS', 'video']
# Plugins --------------------------------------------------------------------    
plugins: [

  auto: yes
  cautious: true
  cover_names: cover front back spine medium art disc discart album folder booklet
  minwidth: 500
  enforce_ratio: yes
  sources: coverart albumart lastfm amazon fanarttv filesystem
  auto: yes
  compare_threshold: 50
  ifempty: yes

  auto: yes
  format: (feat. {0})

  auto: yes
  count: 1
  force: no
  source: track
  whitelist: C:\Users\downloader\AppData\Roaming\beets\genrewhitelist.txt
 # files matching these patterns are deleted from source after import

# use mutliple threads during import
threaded: yes
timeout: 5.0
verbose: no

    auto: yes

    format: $albumartist - $album - $track - $title
    count: no
    total: no
  fields: comments

09-28-2021 -  18_55_58 - Downloader - downloader - Remote Desktop Connection
09-28-2021 -  18_56_05 - Downloader - downloader - Remote Desktop Connection

Ah, you will want to use albumartist, not the plural albumartists.

1 Like

sorry, the way it’s been explained, it HAS to be the albumartists field …this is for proper categorization of soundtracks in Kodi
I’ll note that i found a workaround to my kodi issue by setting the albumtype from soundtrack to compilation…but that makes different issue …a couple different issues actually. In a nutshell, i’m basically trying to make a proper library that populates into kodi and i don’t have to go fix onesy, twosy items. regular artists and bands work just fine…soundtracks and compilations have always been a problem (for me at least), I don’t agree that the albumartists tag should be used in the first place to decide placement…but that’s what it is , so i’ve read and been told

Ah, I see… albumartists, FWIW, was only added as a tag mapping in very recent versions of MediaFile. So you may need to update that dependency before beets can read and write it:

1 Like

I feel like you just “spoon fed” me the answer, but idk if i’m implementing it right… I grabbed the mediafile.py from


by copying the raw contents and replacing the existing mediafile.py, but i don’t see any different in the albumartists field. still blank. Did i not grab the correct file?

Disregard, I found a different way to categorize things like soundtracks in Kodi and this is no longer required. Thank you for your support. Always appreciated

@shredder_guitarist Would you care to share? It might be helpful to other Kodi users who come across this thread.

Music structure should be a main folder and seperate subs for anything that you want to break out from that.
./various Artists
install a plugin called “Library node editor” use that to alter the artists path to include anything containing ./Artists (normal music),
Create a new node called “Soundtracks”
create a rule for that node that indicates “Album” contains path ./Soundtracks
in beats, modify -a query albumtype=“Soundtrack”
Same process for compilations in kodi
in beats modify -a query comp=“true”
make sure that your library sources in kodi are defaulted to “local info only” then once inside the library scan everything in the node with the universal scraper to pick up additional metadata (logo’s discart, etc)

1 Like