Where is beets web in Ubuntu 16.04 LTS


#1

I cannot get the web interface to launch. Is it just not available in Ubuntu?

No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 16.04.5 LTS
Release:	16.04
Codename:	xenial
beets version 1.4.7
Python version 2.7.12
no plugins loaded
~$ beet web
error: unknown command 'web'
~$ beet 
Usage: 
  beet COMMAND [ARGS...]
  beet help COMMAND

Options:
  --format-item=FORMAT_ITEM
                        print with custom format
  --format-album=FORMAT_ALBUM
                        print with custom format
  -l LIBRARY, --library=LIBRARY
                        library database file to use
  -d DIRECTORY, --directory=DIRECTORY
                        destination music directory
  -v, --verbose         log more details (use twice for even more)
  -c CONFIG, --config=CONFIG
                        path to configuration file
  -h, --help            show this help message and exit

Commands:
  config            show or edit the user configuration
  fields            show fields available for queries and format strings
  help (?)          give detailed help on a specific sub-command
  import (imp, im)  import new music
  list (ls)         query the library
  modify (mod)      change metadata fields
  move (mv)         move or copy items
  remove (rm)       remove matching items from the library
  stats             show statistics about the library or a query
  update (upd, up)  update the library
  version           output version information
  write             write tag information to files
$ sudo -H pip install flask-cors
Collecting flask-cors
  Downloading https://files.pythonhosted.org/packages/d1/db/f3495569d5c3e2bdb9fb8a66c54503364abb6f35a9da2227cf5c9c50dc42/Flask_Cors-3.0.6-py2.py3-none-any.whl
Requirement already satisfied (use --upgrade to upgrade): Six in /usr/lib/python2.7/dist-packages (from flask-cors)
Requirement already satisfied (use --upgrade to upgrade): Flask>=0.9 in /usr/local/lib/python2.7/dist-packages (from flask-cors)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.10 in /usr/local/lib/python2.7/dist-packages (from Flask>=0.9->flask-cors)
Requirement already satisfied (use --upgrade to upgrade): itsdangerous>=0.24 in /usr/local/lib/python2.7/dist-packages (from Flask>=0.9->flask-cors)
Requirement already satisfied (use --upgrade to upgrade): Werkzeug>=0.14 in /usr/local/lib/python2.7/dist-packages (from Flask>=0.9->flask-cors)
Requirement already satisfied (use --upgrade to upgrade): click>=5.1 in /usr/local/lib/python2.7/dist-packages (from Flask>=0.9->flask-cors)
Requirement already satisfied (use --upgrade to upgrade): MarkupSafe>=0.23 in /usr/lib/python2.7/dist-packages (from Jinja2>=2.10->Flask>=0.9->flask-cors)
Installing collected packages: flask-cors
Successfully installed flask-cors-3.0.6
You are using pip version 8.1.1, however version 18.0 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
$ sudo -H pip install flask-cors flask
Requirement already satisfied (use --upgrade to upgrade): flask-cors in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): flask in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): Six in /usr/lib/python2.7/dist-packages (from flask-cors)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.10 in /usr/local/lib/python2.7/dist-packages (from flask)
Requirement already satisfied (use --upgrade to upgrade): itsdangerous>=0.24 in /usr/local/lib/python2.7/dist-packages (from flask)
Requirement already satisfied (use --upgrade to upgrade): Werkzeug>=0.14 in /usr/local/lib/python2.7/dist-packages (from flask)
Requirement already satisfied (use --upgrade to upgrade): click>=5.1 in /usr/local/lib/python2.7/dist-packages (from flask)
Requirement already satisfied (use --upgrade to upgrade): MarkupSafe>=0.23 in /usr/lib/python2.7/dist-packages (from Jinja2>=2.10->flask)
You are using pip version 8.1.1, however version 18.0 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
$ beet web
error: unknown command 'web'

#2

Looks like you haven’t enabled the web plugin in your configuration yet.


#3

Affirmative:

$ beet config
{}

however, where is this explained simply? I looked in the FAQ and in the manual, but it isn’t clear in a TL;DR fashion.

I believe I want CORS support but I can wait to figure that part out.


#4

Also, I tried to define the web parameters from the command line and it still said it didn’t work so … why?


#5

I’m afraid TL;DR won’t cut it. :slight_smile: You can find detailed instructions on how to enable plugins on the documentation page about plugins.


#6

do you have an example configuration file that includes the web plugin anywhere?
also, you could have just said:
nano (output of beet config -p)
add the following INSIDE THE {}:
plugins: web