[Solved] Beets update removes metadata

Hello,
I’ve added all my music library in beets, everything was working fine, but today I wanted to try to update the tags, so I tried it first using the -p flag, but it seems like beets want’s to remove some tags from some songs (not all of them).

I don’t understand why beets wants to do this and because of this I can’t use the update command, which is quite annoying.

plugins: discogs inline convert fetchart missing lastgenre scrub ftintitle web bandcamp extrafiles
directory: /music
library: /config/musiclibrary.db
threaded: yes
original_date: no
per_disc_numbering: yes

import:
copy: yes
move: no
write: no
timid: yes
incremental: yes
resume: ask
log: /config/beet.log

replace:
'[\\/]': ''
'^\.': ''
'[\x00-\x1f]': ''
'[<>:"\?\*\|]': ''
'\.$': ''
'\s+$': ''
'^\s+': ''

item_fields:
u_disc: |
if disctotal > 1:
return "Disc {:02}".format(disc)
return ""
album_fields:
u_format: |
item = items[0]
if item.format == "FLAC" and item.bitdepth == 24:
return "FLAC24"
return item.format
u_version: |
item = items[0]
cat = item.catalognum
year = item.original_year
country = item.country
media = item.media
if cat == "[none]":
cat = ""
if "Vinyl" in media:
media = "Vinyl"
elif "Digital Media" in media:
media = "WEB"
list = []
for i in [cat, year, country, media]:
if i != "" and i != 0:
if type(i) != str:
i = str(i)
list.append(i)
return " ".join(list)
paths:
default: %first{$albumartist}/$album ($year) %if{$u_version,{$u_version$} }[$u_format]/%if{$u_disc,$u_disc/}$track - $title
comp: Compilations/$album ($year) %if{$u_version,{$u_version$} }[$u_format]/%if{$u_disc,$u_disc/}$track - $title

convert:
auto: no
dest: /MP3
ffmpeg: /usr/bin/ffmpeg
format: mp3
max_bitrate: 320
embed: yes


lastgenre:
auto: yes
source: album

fetchart:
auto: no

scrub:
auto: no

ftintitle:
auto: yes

web:
host: 0.0.0.0
port: 8337

Here is what beets shows in the console (here it is just for one song):

Stevie Wonder - Conversation Peace - Sensuous Whisper
artist_sort: Wonder, Stevie ->
artist_credit: Stevie Wonder ->
albumartist_sort: Wonder, Stevie ->
albumartist_credit: Stevie Wonder ->
genre: Soul -> R&B
month: 03 -> 00
day: 21 -> 00
tracktotal: 13 -> 00
disc: 01 -> 00
disctotal: 01 -> 00
mb_trackid: 79d045a7-71dc-49a7-bdf2-43c00f92eba4 ->
mb_albumid: 314c854d-129c-4dc3-9799-f9778dcc767c ->
mb_artistid: 1ee18fb3-18a6-4c7f-8ba0-bc41cdd0462e ->
mb_albumartistid: 1ee18fb3-18a6-4c7f-8ba0-bc41cdd0462e ->
mb_releasetrackid: d12abb2d-151a-30c5-ad21-ed80d103ce88 ->
albumtype: album ->
label: Motown Records ->
mb_releasegroupid: 96f22cb3-70e8-3628-99e6-541bf85b774a ->
asin: B000001ALK ->
catalognum: 314530238-2 ->
script: Latn ->
language: eng ->
country: US ->
albumstatus: Official ->
media: CD ->
original_year: 1995 -> 0000
original_month: 03 -> 00
original_day: 21 -> 00

Thanks in advance.

Beets is telling you that the files don’t have data in those tags. The update command wants to bring those changes (i.e., deletions) into the database.

But why are those files missing metadata for those tags? It’s a good question, but impossible to answer just by looking at beet update—the actual cause happened sometime in the past. Might be worth looking into!

Is there any way I could know the cause of this (and maybe revert it) or do I have to re-import all of my music?

That’s the thing—it’s impossible to tell what the cause of this is just by looking at the current state of the files! It could be anything, including some other tool not related to beets at all. The best thing to do might be to retrace your steps and try to see what might have happened along the way, in the past, to cause this to happen to your files.

You might also consider running beet write, which is the opposite of beet update and writes the information from the database to files’ tags.

Alright thank you so much for your answers, I see you are the creator of beets, thank you so much for this amazing tool.

Marked as solved.