Missing track times


#1

I just did a large initial import using the -q and --from-scratch flags, and I discover that none of the imported tracks have track length tags set…
My config:

directory: /mnt/Gog/Music
library: ~/.config/beets/musiclibrary.db
import:
    move: yes
plugins: 
    web:
        include-paths: true
    discogs:
    fromfilename:
    fetchart:
        sources:
        - filesystem
        - coverart: release
        - coverart: releasegroup
        - '*'
        enforce_ratio: yes
    mbcollection:   
    info:
    scrub:
bandcamp:
    art: true
original_date: yes
info:
musicbrainz:
    user: XXXXX
    pass: XXXXX
mbcollection:
    auto: yes
    collection: XXXXXXXXXXXXXXXXXX
    remove: yes
paths:
    default: %title{$albumartist}/%title{$album}/$track %title{$title}
    singleton: $artist/$artist - %title{$title}
    comp: $album/$track $artist - %title{$title}

This is a rather important omission - what did I do wrong?


#2

Hi! What do you mean by “have track length tags set”? How are you checking for track lengths?

Most (all?) audio formats don’t have an ordinary tag field for length; it’s part of the audio metadata.


#3

What I mean is that beet stats reported a total length of zero seconds for the entire database…
I’m currently re-importing without the --from-scratch flag and it appears to be working as expected this time…


#4

Not an expert at all, but I noticed that, too when using from scratch. All I did was “beet update” after my import.