Importing album with HTOA track 0

Hi, I’m running into a problem importing this album:

Here’s what beets displays on import:

/Volumes/Music/import/Guster/1997 - Goldfly (11 items)
    Guster - Goldfly
(Similarity: 79.5%) (tracks) (CD, 1997, US, Aware Records, AWA 107)
 * 00. (HTOA).flac (#0)     -> Great Escape (#1) (title)
 * Demons (#3)              -> Demons (#2)
 * Perfect (#4) (3:30)      -> Perfect (#3) (4:23) (length)
 * Airport Song (#5) (3:56) -> Airport Song (#4) (3:30) (length)
 * Medicine (#6) (3:28)     -> Medicine (#5) (3:56) (length)
 * X-Ray Eyes (#7) (4:18)   -> X-Ray Eyes (#6) (3:28) (length)
 * Grin (#8) (4:43)         -> Grin (#7) (4:18) (length)
 * Getting Even (#9) (2:37) -> Getting Even (#8) (4:43) (length)
 * Bury Me (#10) (4:02)     -> Bury Me (#9) (2:37) (length)
 * Great Escape (#2) (4:27) -> Rocketship (#10) (4:02) (title, length, index)
[A]pply, More candidates, Skip, Use as-is, as Tracks, Group albums,
Enter search, enter Id, aBort?

I found an old issue which suggests that beats should support this if another library is updated:

Does anyone know if this should work? Am I missing something?

I just noticed that the per_disc_numbering documentation says:

When this option is off (the default), even “pregap” hidden tracks are numbered from one, not zero, so other track numbers may appear to be bumped up by one. When it is on, the pregap track for each disc can be numbered zero.

I have per_disc_numbering on, so maybe this is only a problem with musicbrainz?

Hmm; it looks like it’s numbered right in MB. I’m not entirely sure what to suggest—if you’re feeling up for it, maybe consider diving into the beets.autotag.apply_metadata function and printing out a few values to see if you can see what’s going wrong for that track?

Or, it might just be a problem in the printouts from the importer. You could try applying the match and then seeing if it does the right thing (even though it doesn’t say that it will).

Thanks for the idea, I tried to import to see what would happen and it seemed screwed up so I did some more digging and it looks like CueTools screwed up the tags when it made the files that I was trying to import :roll_eyes:

I fixed the tags and then reimported them and it showed this:

/Volumes/Music/import/Guster/1997 - Goldfly (11 items)
    Guster - Goldfly
(Similarity: 100.0%) (CD, 1997, US, Aware Records, AWA 107)
 * Melanie (#0) -> Melanie (#1)

I checked that and despite the above change mentioned it looks like it did it correctly. The file is named with ‘00’ and the tag says track number 0.

Thanks for the help, it’s greatly appreciated!

Great!! Maybe we should consider fixing that output in the importer to make it more obvious what’s going on with “track zero”…

I opened this if it helps:

1 Like