Fresh install - web nor chroma plugins will load

#1

Hi folks,

I’ve been playing with plain beets until I found an issue with an album and found out that chroma could possibly help on sorting it out so I wanted to give it a go.

I installed beets on ubuntu 18.10 with apt and then followed the steps on the docs to install chroma

I also tried to install web plugin.

This is the output of pip list --local

audioread (2.1.6)
beets (1.4.7)
certifi (2019.3.9)
chardet (3.0.4)
Click (7.0)
enum34 (1.1.6)
Flask (1.0.2)
Flask-Cors (3.0.7)
idna (2.8)
itsdangerous (1.1.0)
jellyfish (0.6.1)
Jinja2 (2.10.1)
MarkupSafe (1.1.1)
munkres (1.1.2)
musicbrainzngs (0.6)
mutagen (1.42.0)
pyacoustid (1.1.5)
PyYAML (5.1)
requests (2.21.0)
six (1.12.0)
Unidecode (1.0.23)
urllib3 (1.24.1)
Werkzeug (0.15.2)

This is what I get when I run beet version

** error loading plugin chroma:
Traceback (most recent call last):
  File "/usr/share/beets/beets/plugins.py", line 270, in load_plugins
    namespace = __import__(modname, None, None)
  File "/usr/share/beets/beetsplug/chroma.py", line 27, in <module>
    import acoustid
ModuleNotFoundError: No module named 'acoustid'

** error loading plugin web:
Traceback (most recent call last):
  File "/usr/share/beets/beets/plugins.py", line 270, in load_plugins
    namespace = __import__(modname, None, None)
  File "/usr/share/beets/beetsplug/web/__init__.py", line 23, in <module>
    import flask
ModuleNotFoundError: No module named 'flask'

beets version 1.4.7
Python version 3.6.7
plugins: convert, inline

Any ideas?

0 Likes

#2

Maybe your issue is similar to this?

1 Like

#3

Hey @dorade, thanks for that, I didn’t find that one! I definitively tried removing them all and start over but I’ll give a another go.

Have you noticed I get the same sort of error for web plugin as well? it’s funny beets reports python 3.6.7 and I think I remember to have seen these packages under 2.7 directory structure…uhm

Is it possible beets is trying to use 3.x where pip installed packages for 2.7? Does that make sense?

0 Likes

#4

Yes, that’s possible! You’ll need to be sure you’re invoking “the right pip” when you install things. On some systems, for example, the pip for Python 3 is called pip3.

0 Likes

#5

Thanks @adrian, I’ll give it a try when I get home :smiley:

That was it. I installed python3-pip and pip3 install dependencies and got it working.

How do I mark the thread as solved? I don’t seem to find that option either haha

0 Likes