Discog plugin (and others) failing to load


#1

Hi all.

I haven’t been using beets for a couple of weeks. I used it now and I noticed some strange errors I never got before.

I’m parting the output for the discogs plugin, but I also get quite similar errors for fetchart and lyrics

** error loading plugin discogs:
Traceback (most recent call last):
File “c:\personal\python27\lib\site-packages\beets\plugins.py”, line 270, in load_plugins
namespace = import(modname, None, None)
File “c:\personal\python27\lib\site-packages\beetsplug\discogs.py”, line 26, in
from discogs_client import Release, Master, Client
File “c:\personal\python27\lib\site-packages\discogs_client_init_.py”, line 6, in
from discogs_client.client import Client
File “c:\personal\python27\lib\site-packages\discogs_client\client.py”, line 15, in
from discogs_client.fetchers import RequestsFetcher, OAuth2Fetcher, UserTokenRequestsFetcher
File “c:\personal\python27\lib\site-packages\discogs_client\fetchers.py”, line 2, in
import requests
File “c:\personal\python27\lib\site-packages\requests_init_.py”, line 53, in
from .packages.urllib3.contrib import pyopenssl
File “c:\personal\python27\lib\site-packages\requests\packages\urllib3\contrib\pyopenssl.py”, line 53, in
import OpenSSL.SSL
File “c:\personal\python27\lib\site-packages\OpenSSL_init_.py”, line 8, in
from OpenSSL import rand, crypto, SSL
File “c:\personal\python27\lib\site-packages\OpenSSL\SSL.py”, line 124, in
SSL_ST_INIT = _lib.SSL_ST_INIT
AttributeError: ‘module’ object has no attribute ‘SSL_ST_INIT’

I just updated beet using pip to the latest version (1.4.7). I use python 2.7.9 on Windows 7.


#2

Wow; that’s weird! Have you considered reinstalling Python? A more recent version of Python would also probably be a good idea; 2.7.9 is more than four years old.


#3

I could consider that. After all I don’t use python on this machine for much except for beets, so I don’t risk much regressions.

What if I switched to python 3?


#4

Seems like a good idea.


#5

I brutally updated python by installing the laterst 2.7 release in my current folder.

Now I tried and everything worked as a cherm. I even tried importing an album directly providing the Discogs release IR with the -S switch and it worked flawlessly.

Thanks.