Beets dont start for a while with error: can only concatenate list (not “_NamespacePath”) to list

hello my beets won’t start. Does anybode know why? I tried to remove the config, but it didn’t helped.

I get the following terminal output:

>beet --version
Traceback (most recent call last):
File “/usr/bin/beet”, line 33, in
sys.exit(load_entry_point(‘beets==1.4.9’, ‘console_scripts’, ‘beet’)())
File “/usr/lib/python3.8/site-packages/beets/ui/”, line 1266, in main
File “/usr/lib/python3.8/site-packages/beets/ui/”, line 1249, in _raw_main
subcommands, plugins, lib = _setup(options, lib)
File “/usr/lib/python3.8/site-packages/beets/ui/”, line 1135, in _setup
plugins = _load_plugins(config)
File “/usr/lib/python3.8/site-packages/beets/ui/”, line 1114, in _load_plugins
beetsplug.path = paths + beetsplug.path
TypeError: can only concatenate list (not “_NamespacePath”) to list

I use Version 1.4.9-4 on Arch Linux with python 3.8.5-2.

Hi there! This is super weird, but it has cropped up seemingly at random for a few other users recently:

I’m not sure what’s causing it. But maybe cross-comparing with that thread will yield some clues?

1 Like

I triggered this recently by running pip3 --devel . in the Git repo to install Beets. Reinstalling without --devel fixed the issue.

Maybe it’s related. Do you have anything Beets-related in your personal Python libdir? (probably ~/.local/lib/python3.8)

1 Like

Thank to you two, I could fix it with your help. As Victrid said in the last post in the issue and @samthursfield in this forum, the problem was my .local/lib/python3.8 path. I installed the beets-extrafiles plugin with the following command:

pip3 install --user beets-extrafiles

That was recommended from the Tutorial on PyPI. So I removed it from my user installation and install it as root.

sudo pip3 install beets-extrafiles

Now it works. Thank you all!

As I read that the other person with the problem has Arch Linux too, I wonder if this is Arch Linux related problem. Or is the issue known from other distros too?

I experienced this on Fedora 33. It may be a recent issue with Python 3.8 / 3.9.

1 Like

While I’m still sort of stumped about the root cause, this should avoid the problem:

1 Like