Import using fromfilename to overwrite


Apologies for the rookie question in case I missed an answer elsewhere.

  • Compilation album has incorrect metadata (artist is incorrectly albumartist)
  • Autotagger doesn’t suggest the right album
  • Filenames of the audio files have the original artist and track name (in the format 01-artistfirstname_artistlastname_title_original_mix.mp3)

I would like to use “fromfilename” to extract the artist and update.

Any advice would be valuable.

P.S. I am assuming fromfilename is auto-installed. My config.yaml lists it in plugins and “beet version” returns plugins: edit, fromfilename, lastgenre

Thanks in advance,

Hi! All of that sounds reasonable—but I think the problem you’re (probably) encountering is that fromfilename only actually does its thing if the original files are missing their metadata (i.e., the titles are empty). So if the tracks already have (wrong) tags, it won’t work.

Yes, I assumed that was the issue. Tried adding --from-scratch but got the same result. Anything else I could try?

You could try manually removing the tags from the files before importing them.

Ahh, I was hoping that wasn’t the answer :slight_smile:

Thank you

it also wouldn’t be too hard to patch the fromfilename plugin to accept a config option to force reading tags from the files.