Beatport plugin not creating matches / not working?


#1

I’ve been trying to sort through my library of mostly house/techno music and using the autotagger. However, with this kind of music neither Discogs or Musicbrainz are ideal, Beatport is my preferred tag source as the vast majority of my tracks are available there.

However, when i am importing I cannot see any matches created by the Beatport plugin, only Discogs and Musicbrainz results. In my config file I have “Plugins: beatport” and have installed the relevant libraries as per the documentation guide. Is there any obvious reason this plugin wouldn’t be working? I am pretty new to this so haven’t gotten the hang of what i’m doing yet. Thanks in advance.


#2

Hmm; there’s always a chance something’s going wrong with the communication with the Beatport API that we haven’t addressed yet. Is there anything interesting in the verbose output?


#3

I restarted the import and pasted the cmd window contents here. And here is my conifg file.

I’m still just getting to grips with this so I’m probably just doing something simple wrong.


#4

That doesn’t seem to be in verbose mode (you’ll want to use the -vv flag). Please try that and look specifically for messages from the Beatport plugin.


#5

Sorry I didn’t know I had to use -vv. I ran it againin Verbose mode and couldn’t find any references to the beatport plugin.

I tried deleting the beatport token.json file, however when I subsequently tried to import I didn’t get an authentication prompt for beatport and there is still no sign of it in the verbose output.

Thanks for your help!


#6

Thanks for trying again!

I think the problem is in these suspicious lines in your config file:

Plugins: beatport
plugins: discogs

You’ll want to declare this only once, and always in lower case. That is:

plugins: discogs beatport

#7

That was the issue -appears to be working now, thanks very much! Just while I have you here, do you know if it’s possible to prioritize the Beatport plugin over MusicBrainz?


#8

You can use source_weight (an undocumented option, I believe) to control prioritization. Googling for other threads about source_weight is probably a good way to get started.


#9

Ah excellent, thanks