[SOLVED] Genre tag (lastgenre or whatlastgenre)


#1

Hi all.

I love beets and it almost meets my every need. However I’ve had issues with the lastgenre plugin for awhile now. Long story short, the plugin doesn’t seem to do anything, probably because lastfm doesn’t use tags anymore from what I can tell. This has been an issue for a long time, I’m obviously missing something here in my config maybe?

So I tried switching to whatlastgenre but every time I try run import I get a module not found error.

ModuleNotFoundError: No module named 'beetsplug.whatlastgenre'

This is on Archlinux btw. The docs say you just need to have it installed on your system, which I did through the AUR. There is also the plugin path option, which shouldn’t be necessary as I can see ‘whatlastgenre’ under /usr/bin


#2

Interesting! I don’t know anything about whatlastgenre, but it’s bad that lastgenre isn’t doing anything. Any chance you could include some verbose logs to depict what’s going wrong?


#3

Thanks for pointing me in the right direction. It looks like it was the zero plugin that was actually erasing the genre tag. It also looks like you need to indicate both genre and genres for not being nulled or they end up getting blanked out. If you list the fields with “beet fields” there is no genres listed as a field, nonetheless if it is not also indicated in the option keepfields: in my case, the genre field gets erased.